For each new version of WordPress, the Hosting Team releases an article examining compatibility between PHP and new WordPress versions, offering recommendations for that specific WP version. Here are the Hosting Team’s recommendations for WordPress 6.9!
Before reading, you may want to check out the team’s previous posts highlighting recommendations for WordPress 6.8, WordPress 6.7, WordPress 6.6, WordPress 6.5, WordPress 6.4, and WordPress 6.3.
Please note, the goal isn’t to discuss WordPress compatibility or backwards compatibility, but rather to support hosts in architecting the ideal experience for new WordPress installations, and to guide sysadmins in upgrading sites in the optimal way.
This post goes into detail about compatibility, including the idea of “beta compatible”.
So, please continue reading for compatibility information, updated for WordPress 6.9.
Hosting Team Recommendations
The Hosting Team recommends Hosts use the following minimum versions for streamlined compatibility with WordPress 6.9 – (Note: these may differ from the global recommendations):
- PHP: 8.3.x, 8.4.x
- MySQL: 8.0.x, 8.4.x
- MariaDB: 10.11.x, 11.4.x
IMPORTANT: These recommendations are primarily intended for new installations by hosting providers. For optimal performance and security, always use the latest compatible versions on new installs rather than setting up new WordPress websites with old PHP and Database Engine versions.
Where do the recommendations come from? The Hosting Team reviewed a variety of modern hosting configurations, PHP lifecycle status, database engine maturity, and WordPress Core compatibility work. Based on this review, these versions provide the most stable and forward-looking environment for WordPress 6.9.
WordPress server requirements
WordPress supports backwards compatibility, so even when there are more stable software versions available, that doesn’t mean they are the ones that WordPress recommends.
The current minimum WordPress 6.9 requirements are:
- PHP: 7.4+
- MySQL: 5.7+
- MariaDB: 10.3+
Folks can read more about minimum requirements here: Server requirements.
WordPress’ compatibility “at the time”
WordPress 6.9 (released in the end of 2025) aligns with the following software versions available at release time (stable or security-maintained versions only, and RC versions for informational purposes):
PHP
- 8.2 (Security Support)
- 8.3 (Security Support)
- 8.4 (Active Support)
- 8.5 (Active Support)
MySQL
- 8.0 (LTS)
- 8.4 (LTS)
- 9.6
MariaDB
- 10.6 (LTS)
- 10.11 (LTS)
- 11.4 (LTS)
- 12.1
Web Servers
- Apache HTTPD: 2.4
- nginx: 1.26, 1.27
- LiteSpeed Enterprise: 6.2.x, 6.3.x
- OpenLiteSpeed: 1.7.x, 1.8.x
Note: PHP has extended Security Support for multiple PHP 8.x releases. New PHP versions may enter candidate support status during the WordPress 6.9 lifecycle.
Please read more at: WordPress Compatibility.
WordPress and PHP
PHP is the primary programming language used by WordPress Core. Because PHP executes on the server, keeping it up to date is critical for both security and performance.
WordPress continues to support a wide range of PHP versions, including some that are end-of-life, to maintain backward compatibility. Hosts and site owners are strongly encouraged to run supported PHP versions wherever possible.
WordPress supports many versions of PHP, even some that are obsolete (Check out PHP Compatibility and WordPress Versions).
WordPress 6.9 (core) is:
- Fully compatible with PHP 7.4 (1), 8.0 (1), 8.1 (1), 8.2, and 8.3
- Beta compatible with PHP 8.4 and PHP 8.5
(1) SECURITY ALERT: Some older PHP versions are no longer officially maintained by the PHP project and are considered insecure. Users should consult their hosting provider regarding security backports or upgrade paths if running an older PHP version.
To explore all WordPress development tickets related to PHP, see: Trac PHP Search.
What Does “Beta Compatible” Mean?
Beta compatibility means WordPress Core is actively working toward full compatibility with a PHP version, but some issues may still be under review or pending resolution.
When using a beta-compatible PHP version:
- Deprecation notices may appear in logs, wp-admin, or front-end output
- Deprecation notices are not errors
- Functionality is not broken, but additional compatibility work is ongoing
PHP 8.4
- Deprecation notices may be visible
- Deprecations do not break functionality
- WordPress Core compatibility work is ongoing
- Prepare for PHP 8.4: Trac #62061Status: Closed / Fixed
PHP 8.5
- Initial compatibility work has begun
- Deprecation notices may be present
- Full compatibility is expected in a future WordPress releases
- Prepare for PHP 8.5: Trac #63061 Status: Closed / Fixed
Other related tickets
PHP
- #51525: Add new functions apply_filters_single_type() and apply_filters_ref_array_single_type()
Status: Moved to Future Release - #54183: Tests: decide on how to handle deprecations in PHPUnit
Status: Moved to Future Release - #54537: Tests: Enable PHP version check once PHP 8.0 compatibility is achieved
Status: Moved to Future Release - #58874: Code modernization: consider using the null coalescing operator
Status: Moved to Future Release - #59234: Introduce a wp_json_decode() function, including validation when available
- Status: Closed, not moving forward
Upgrading WordPress
Do you have a version earlier than WordPress 6.9?
If so, the Hosting Team recommends you visit the Upgrading WordPress page for more information on how to upgrade from WordPress 0.7 all the way to WordPress 6.9.
Anything else? Feel free to comment below!
Props to @sohilvahora96 @chrisdavidmiles @desrosj @codexdemon and @jazzs3quence for collaborating on this post!