WordPress 6.8 Server Compatibility


It’s that time again, folks! Here are the Hosting Team’s recommendations for WordPress 6.8! For more context, feel free to check out the team’s previous posts highlighting recommendations for WordPress 6.7, WordPress 6.6, WordPress 6.5, WordPress 6.4, and WordPress 6.3. For each new version of WordPress, the Hosting Team aims to release an article examining compatibility between PHP and new WordPress versions, and offer recommendations for that specific WP version.

Please note, the goal isn’t to discuss WordPress compatibility or backwards compatibility, but rather to support hosts in architecting the ideal experience for new WordPress installations, and to guide sysadmins in upgrading sites in the optimal way.

This post goes into detail about compatibility, including the idea of “beta compatible”.

So, please continue reading for compatibility information, updated for WordPress 6.8.

Hosting Team Recommendation

The Hosting Team recommends Hosts use the following minimum versions for streamlined compatibility with WordPress 6.8: (note: these may differ from the global recommendations).

  • PHP: 8.2.x, 8.3.x
  • MySQL: 8.0.x, 8.4.x
  • MariaDB: 10.11.x, 11.4.x

IMPORTANT: These recommendations are primarily intended for new installations by hosting providers. For optimal performance and security, always use the latest compatible versions on new installs rather than setting up new WordPress websites with old PHP and Database Engine versions.

Where do the recommendations come from? The team reviewed a variety of configurations and options, and concluded these are the best ones!

WordPress server requirements

WordPress supports backwards compatibility, so even when there are more stable software versions available, that doesn’t mean they are the ones that WordPress recommends.

The current minimum WordPress 6.8 requirements:

  • PHP: 7.2.25+
  • MySQL: 5.5.5+
  • MariaDB: 5.5.5+

Folks can read more about minimum requirements here: Server requirements.

WordPress’ compatibility “at the time”

WordPress 6.8 (released on April 15, 2025) has the following components available (stable or security-maintained versions only, and RC only for informational purposes):

  • PHP: 8.1 (Security Support), 8.2 (Active Support), 8.3 (Active Support), and 8.4 (Candidate Support).
  • MySQL: 8.0 (LTS), 8.4 (LTS), and 9.1.
  • MariaDB: 10.5 (LTS), 10.6 (LTS), 10.11 (LTS), 11.4 (LTS), and 11.5.
  • Apache HTTPD: 2.4.
  • nginx: 1.26, and 1.27.
  • Litespeed Enterprise 6.2.x, 6.3.x
  • OpenLiteSpeed 1.7x , 1.8x

NOTE: PHP has extended the Security Support one extra year for (PHP 8.1, 8.2, 8.3, and 8.4) and new PHP versions.

Please read more at: WordPress Compatibility.

WordPress and PHP

PHP is the main programming language on which WordPress code is based. This language runs on the web server, and because of that it is critical to keep PHP software up to date on the server, both for security and functionality.

WordPress supports many versions of PHP, even some that are obsolete (Check out PHP Compatibility and WordPress Versions).

WordPress 6.8 (core) is:

  • fully compatible with PHP 7.2 (1), 7.3 (1), 7.4 (1), 8.0(1), 8.1, and 8.2.
  • beta compatible with 8.3 and 8.4.

(1) SECURITY ALERT: Some older versions of PHP are no longer officially maintained by PHP, and are considered insecure and obsolete versions that should not be used in production. Users should check with your hosting provider about the security maintenance they can do if you’re running an older version of PHP on your server.

Looking for all the WordPress development tickets related to PHP? Take a look at this Trac PHP Search.

What does “beta” mean?

Beta support means that WordPress Core is working towards full compatibility with that PHP version, but there may still be some issues that are in the process of being resolved. Below are tickets outlining known issues regarding beta support for PHP 8.3 and 8.4. More on when a PHP version goes from beta to fully supported is documented by the core team.

PHP 8.3

  • Deprecation notices. A deprecation notice is not an error, but rather an indicator of where additional work is needed for compatibility before using future versions, like PHP 9.0. With a deprecation notice, the PHP code will continue to work and nothing is broken.
  • #59231: Prepare for PHP 8.3.. NOTE: Closed/Fixed
  • #59232: Introduce #[Override] attribute to mark overloaded methods This attribute helps prevent coding errors by making it clear when a method is overloaded. It also assists with refactoring, debugging, and catching potential breaking changes in the parent class. NOTE: Has a patch, but moved to Future Release.
  • #59233: Improve error handling for unserialize(). maybe_unserialize() function could still be confronted by data with trailing bytes. NOTE: Moved to Future Release.

PHP 8.4

  • Deprecation notices. A deprecation notice is not an error, but rather an indicator of where additional work is needed for compatibility before PHP 9.0. With a deprecation notice, the PHP code will continue to work and nothing is broken.
  • #62061: Prepare for PHP 8.4.. NOTE: Closed/Fixed

Other related tickets

PHP

Upgrading WordPress

Do you have a version earlier than WordPress 6.8? 

If so, the Hosting Team recommends you visit the Upgrading WordPress page for more information on how to upgrade from WordPress 0.7 all the way to WordPress 6.8.

Anything else? Feel free to comment below!

#core, #php, #hosting